Search Posts:

Installing Core into PDP 11/40

SHARE

Return to Threads

  Installing Core into PDP 11/40 by Bill Degnan - 05/22/2016 19:44
32K x 16 Core backplanes installed into my working PDP 11/40. Conversation below explains layout. Click image for larger view.


Email to CCTECH:

Background - I have a PDP 11/40 that came to me with a CPU backplane and a general purpose 4 slot peripheral backplane (DD11-C). The CPU backplane came to me connected to the 4 slot via a std 11/40 M981. In the 4-slot I have I have a working 64K solid-state RAM card, M7856 serial card, M9312 bootstrap/console card, and an RL02 drive controller. I can access RAM from the console, run the console program (monitor program) off the M9312 through the serial card. I can't boot yet off the RL02 and I am thinking this is due to a termination issue, not sure yet. I decided I need more backplane to go any farther.

So I decided to insert two 32K core memory backplanes in between the original two backplanes that came with the system. My plan is to replace the solid-state RAM card with core, and this will free up a slot on the 4-slot backplane for a terminator. Am I correct in my logic?

I have connected the "new" backplanes using M920's. Imagine the original system with a core backplane wedged in the middle. Power seems fine, DC LO AC LO fine.

Right now there is nothing in the core backplanes, First I want to verify that I have them arrayed correctly and that I can still communicate with the (now) 4th backplane in the back. I can run "chase the lights" from the console but the serial card seems to have stopped working. It appears that the console program is being loaded and runs from the M9312 but nothing is appearing on the terminal. I cannot send an "A" to the terminal, the most basic test I can think of.

Could be the the M7856 card decided to die on me just now, or something else is wrong. Does anyone have a PDP 11 /05/10/35/40 and have experimented about what you can and can't do with backplanes?

I know that there are a lot of variables here, so I'd like to start with the basics

Basic Question #1
Do I need grant cards in *every* empty slot of the core backplane, including the end slots with the M920's?
Basic Question #2
Can you only use the core backplanes for core memory (assume yes), or are they capable of holding other types of cards temporarily? (yes/no/maybe)

I am researching the system config on my own, but I thought if anyone had any advice I'd love to hear it, make troubleshooting a little easier.

I have read up on the subject:
http://retrocmp.com/how-...pdp-11-unibus-backplane
https://trmm.net/PDP-11

I see this is not a simple little thing. Working to find more GC cards now.

* * * * *

I received a reply from Tony Duell who said remove the grant cards from the core plane.

Stand by for more.


Reply
  SPC Backplane Testing by Bill Degnan - 05/24/2016 01:34
DD11-B four SPC, AB slots in middle for two DF11. DF11 is a serial card. like an M594

DD11-CF four SPC, power harness for BA11-F

Here is a page with the info in detail, thank you CH Dickman.
http://www.chdickman.com/pdp11/Notes/DD11.shtml

Reply
  corrections to card placement by Bill Degnan - 05/24/2016 19:57
copy of CCTECH email

There have been a lot of parallel discussions on my PDP 11/40, I am consolidating them all here:

I now have 5 backplanes installed. Here they are, described in order. I walked through this will Paul Anderson last night (thanks Paul!) to verify everything was in the right place and in the right order, in the right power, etc. The +5V is a little weak but I can tweak it, etc.

1. CPU backplane. This is the same backplane I have had running/working for 10 years. There is no M2737 or M787 installed, just a stock CPU card set. No changes have been made.

2. core backplane #1 32k x 16 - 18 Memory backplane 500344C. This backplane has one set of core cards installed in the order they came from another system. These are electrically ok, but not tested/known to pass memory tests. The M8293 is set to 0000
9/11: M981 (1-2)
11: M8293 (3-6)
12: M7259 (1-2)
13: G114
14: H217C
15: G235

The 2nd half of the 1st core backplane is empty. Photo of CPU and 16K Core installed

3. The 2nd core backplane is empty. There are M920's on either end to connect them

4. The next backplane is a DD11B. This is empty other than grant cards in each slot D.

An M9202 connects the DD11B to the next backplane

5. The final (5th) backplane is a DD11C

In the first slot (closest to the front) GC in slot 4.

In the 2nd there is a M7261 RT11 drive controller. This slot requires a NPG G7273 installed if not in use, the M7761 requires this kind of slot. It's not hooked up to anything (RL02).

In the 3rd slot is a GC card

In the 4th slot I switched back and forth between the terminated M9312 and M930 terminator. In 3 and 4 I have a G7273. The G7273 is required because previously the NPG was removed from wirewrap, this backplane is no longer "stock" because both the 4th and 2nd require NPG.

Ultimately I decided to remove the M9312 terminator/ROM card, and I am using a M930 terminator instead. I also experimented with the MOS RAM in slot 3 but I decided I don't want it installed for now. Only the drive controller and grant cards/terminator remain at the moment.

WHEN I POWER UP - I have full console access, everything "works" and now I have 16K of core. I can save and run "chase the lights" at any point within the 16K.

I have spare core cards to draw upon, I had pulled a good set for my 11/05 I could always use those if need be.

Thanks everyone for your help and suggestions.

NEXT: Double-check power, especially to the rear DD11C backplane. That might explain why I can't boot off the M9312 anymore. I also want to see what I can safely put into the DD11-B backplane, such as the M7856 serial card.

Reply
  RL11 and DL11 by Bill Degnan - 05/26/2016 10:38
See thread
http://www.vcfed.org/for...ackplane-into-PDP-11-40

"...RT-11 will use the card in a vanilla fashion. Basic interrupts for each input and output byte received/sent. No handshaking for modem or CTS/RTS or other control signal support (often called out of band controls). In-band control (in the serial data stream) exists for flow control keys (Control Q, Control S) or interruption (Control C) are provided...."

Reply
  Weird Core Performance by Bill Degnan - 06/01/2016 14:38
System Status
1. I can write to any location in the 16K RAM from 000000.

2. I can turn off the machine and retrieve the RAM

3. If I exam long enough, I get a parity error light on the M2759. If I find an address with an error, I can deposit into the address and return to the address without generating an error. But, if I keep exam-ing I will hit the next address that triggers the parity fail light....

I have been reading up to see if there is something within the CPU cards that is incompatible with the RAM cards. There are many variations and jumpers. Nothing so far obvious pops out as wrong.

Reply
  Testing Serial by Bill Degnan - 06/04/2016 12:29
Checking M7856 and M7800 1488 (send) 1489 (receive) chips. Easy test is to check for the proper voltage at pin 7 and pin 1 = -12v and pins 7 and 14 should = +12v

Using voltmeter I can test RS232 output (1488)
-ground clip to computer
-probe to pin 3 of rs232
-oscilloscope = -5V (OK)

Check oscilloscope on pin 2 of the RS2232 receiver chip (1489)

replace which ever chips are bad using this technique.

stand by...

Reply
  Memory Issue with Core Symptom by Bill Degnan - 06/05/2016 23:35
Rough notes taken during recent analysis of the performance of the system. There is a CPU/memory failure that I cannot yet pin down.

WIthin the MJ11 board set the M7259 has the job of reporting parity errors to the CPU. This is visually represented by the red light that shines when a parity error has occurred. Also the CPU pretty much shuts down anything running.

[Question] PDP 11/40, Power within tolerances. Of the boards that comprise the MF11-UP I have swapped out the G114, M7236, G235, M7259 they seem to be OK and work in other systems. The H217C appears to be at fault or the CPU. Is there a practice to "refresh" a core card? I ask because when I pick a location in RAM and EXAM addresses that I have not yet DEPosited data I get sporadic parity errors. The M7259 light goes off.

If I use another M7259 I get identical results when I EXAM.

Further, Parity errors do not migrate - i.e. if I power off/on good addresses and parity-alert-triggering EXAM addresses pop at the same spot every time. Should I get a parity error all I need to do in order to permanently correct is simply overwrite the address with new data using the front panel.

No new bad parity addresses have appeared. Any RAM location that had a parity error will continue to have one until I overwrite it. Likewise every address that DEposited data will remain OK.

What do I do, reset the entire core somehow?

I have been attempting to diagnose what is going on, making some progress, but I'd love to hear if anyone has ever experienced anything like this.

My plan is to re-check the jumpers on the CPU and make more measurements.

Other than chase the lights, I have not had luck loading the programs that test memory found here:
http://www.psych.usyd.edu.au/pdp-11/hints.html

I don't yet have a working Serial card, hard to install the echo program, something is preventing serial card from working, M9312 does not work. MOS ROM does not work. Why all of this?

Reply
  Core Memory Test OK by Bill Degnan - 06/13/2016 09:09
I found a mistake in the process I was using to test core memory using the Hints on Testing a Dead PDP 11 web page. I did not notice that the Memory Sizing program jumped to location 000 200 and should also be started from there. Once I caught that, I was able to load and run the program successfully.

I can resume hunting for a working serial card that can be configured as a teletype or EIA console access point.

Reply
  Serial Comms OK Again by Bill Degnan - 06/15/2016 17:43
after giving up on the M7856 I had been using (it receives but does not send back to the terminal), and an M7800 I hoped might work (bombs when attempting to do much of anything), I found another M7856, jumpered that one and now I am back in business. I have now 16K core, serial comms and a M9312 ROM/Terminator with RL01/2 and CONSOLE ROMs. Basically I am back where I was before with MOS RAM. The project was to expand the backplane and replace MOS with core RAM. NEXT - get RT11 running.

As far as the original M7856 serial card goes, it appears to have been repaired more than once, some of the traces are bare, simply replacing the 1488/89 is not enough. I can compare the working card with the bad one, that should help diagnose/fix.

Reply
  11/40 Diagnostics by Bill Degnan - 06/20/2016 14:07
Here is a link to diagnostic programs that can be downloaded and run through PDPGUI or manually into the 11/40 through the serial card to test the machine

http://www.retrocmp.com/...e////devices/11-40.html

Reply
  More Diagnostics/results by Bill Degnan - 06/25/2016 08:13
run GKAAA0, CKBA, CKBB CQKC. I am going to make a chart of the registers' values and if there are instructions / docs for each test try to report what appears to be the relevant info to diagnose.

So far I seem to be able to run any diagnostic, at least load and run it. I get a result. It will be interesting to see what comes of this phase of testing.

Here is CKBB
https://www.youtube.com/watch?v=Lg_SLoKlMTs

page 14 of
http://bitsavers.trailin...-B_DCKBE-B_BASIC_CP.pdf

seems to indicate, my interpretation, that the program ran as expected, it loops and there is even a pass counter register. I don't see any error. Per a tip I received, I replaced the bell with an asterisk in 3604 so I could see on the screen that each pass was a success.

------------

CQKC Test
Runs and HALTs at various spots, based on timing of when I depress halt, it's not jammed up.

005712 / 002
005774 / 000
005742 / 002
005746 / 004
005742 - 002
etc.

Reading the code of the program did not reveal too much as to a problem.

getting more into it:


http://bitsavers.trailin...ION_EXERCISER_Sep74.pdf

follow loading and starting procedure.

Reply
  Running CQKC by Bill Degnan - 06/27/2016 12:23
At the end of each pass it's supposed to say:

THE QUICK BROWN fOX JUMPED OVER THE LAZY DOGS BACK
0123456789
PASS # AAAA

I ran this for an hour to see if ANYTHING printed, especially this end of pass message. The doc says an 11/45 with a lot of RAM will complete a pass in 24 minutes. What my 11/40 with 16K will need I don't know, but I can't imagine more than 40 minutes.

If console TTY is a serial device filler characters are required. Deposit into location 1002 a 0 (the filler character) and location 1003 11 octal the filler count.

start address 200
press start
set operating switches

contents of OPT, CP is typed on first pass.
Pass count is printed after each pass
DCQKC DONE is printed when done.

7 = means don't type out the pass typeout - I assume I should leave this switch down.
15 = halt on error - this is the only switch in the up position.

--NOTHING---

Daver2 from vcfed.org/forum says:

"..200( 8 ), 204( 8 ) and 210( 8 ). Starting the program at 204( 8 ) instead of 200( 8 ) should prompt you for the memory limits and ask you for "LOW LIMIT?" and "HIGH LIMIT?". The important thing is 'does it ask you for anything at all'? If not, either your console is not working - or the diagnostic software you have doesn't match the documentation (in which case we will get nowhere)

The listing implies that it detects if a terminal is present by looking at address 177564 and seeing if it times out or not. If it doesn't timeout - then the software should print "OPT.CP=nnnn" at the start stating what options it has found. I guess it has never done this?

EXAMINE memory location 764( 8 ) which should hold the OPT.CP flags to see what it thinks it is running with. Again, this memory location will only be valid for the same version of the diagnostics as the listing describes.

..."

Dave offered to verify that the listing of code matches the actual tape I am using.

It appears that the code is looping here:


5570 / 2 (address/data)
5574 / 4
5600 / 10
5604 / 4
5614 / 10
5622 / 0
5676 / 0
5702 / 0
5706 / 4
5712 / 4
loop back to 5570

see page 99 of the DCQKC instruction exerciser doc.

here is a disassembly of the actual code, the documentation DOES NOT MATCH

Reply
  Install missing KJ11 by Bill Degnan - 06/29/2016 12:46
On a whim I decided to re-check the CPU cards. Turns out I was missing the KJ11 module (M7237) my CPU was expecting. When I got this machine there was no M7237, but the CPU was wired for it. I did not catch this when I originally tested the jumpers of the CPU boards. I now have better info and I was able to check more thoroughly.

The KJ11 is a Stack limit register and that is needed to run BASIC and the Diagnostics. I think the symptom of the code looping above is evidence that there is a IOT Stack issues.

Finding a M7237 (I am lucky to have) and installing into E of slot 3 did the trick. I was able to run the diagnostic. I was able to load and use BASIC.

I still have to run more diagnostics to check things thoroughly.

Hopefully soon I can focus on booting RT11.

Hurrah!

Note about CQKCE0-11-45.bin, remember to load 1002 and set data - 011000 if you're using a serial terminal. I started from 200 with 15 up to HALT on error. As I read the test takes a while for each pass not sure yet how long but I'd say at least 15 minutes.

Reply
  Installing BASIC by Bill Degnan - 06/30/2016 09:40
BASIC initialization.


I installed BASIC from the papertape image through the Memory Loader of the PDPGUI program. There are faster ways to load BASIC, but what's important is to download the tape into the correct memory locations however you can.

The BASIC program initialization starting address is 16104 and the direct start address is 000. You have to run the initialization at least once.

Reply
  More MAINDEC CQKC-D by Bill Degnan - 07/21/2016 20:49
I am consistently getting the following error when I run the Maindec DCQKC-D with the temp replacement M7233 installed, so I put the original one back in the system.

#0000 VPC=020610 PSW=000017

(run with switch 9 up)

VPC = virtual program counter
PSW = PSW at the time of the error.

"The 1st error format shows an error detected when the program is not
relocated, and in this instance VPC=PPC. The error is probably a CP error. CP=central processor.

Reply

Resources:


Buy a Commodore Computer Poster

Popular Topics and FAQs


Past Issues:


simon3

This image was selected at random from the archive. Click image for more photos and files from this set.