Search Posts:

Cromemco System One


Return to Threads

  Cromemco System One by Bill Degnan - 11/30/2006 19:12
I have just started working on this computer. I received it partially unassembled. I am unsure whether it worked or not. Fun.

Cromemco System One Pics

First I downloaded a copy of the System One user's guide, and using that document set the dip switches and cable up the computer. I also removed the Cromemco TU ART card card because the stock System One does not come with it and I wanted to start from stock first. I have to read the manual to determine how it interacts with the rest of the "stock cards"

Here are pics of the cards that come with the System One.

Cromemco 16 KZ memory card

Cromemco PRI card

Cromemco Z80 "ZPU" processor card

Cromemco 16FDC drive controller

I do not know for sure how to cable up the computer, this is what I am working on now. The user's guide does not explain this, although there is an illustration with most of the cabling visible. Why the seller felt it necessary to unplug all the cables to deliver to me locally I don't know. At least he found the key!

There was a diskette in the drive, and it was an IBM-brand disk I assume is a Cromemco boot disk, but there is no label as such. The drives do not spin or light up, so I can't tell yet.

There appears to have been some modification to the base system. In the 16FDC card the RDOS 2.52 chip has pins 16 and 17 soldered together, assuming 16 and 17 are the 4th and 5th pins on the right, from the "dimple" end of the chip. Locate the IC 25 and the "DC" text printed on the board 16FDC BDOS

The TU ART has many functions, and I am unsure exactly how this card worked with the rest of the system. I will work on this problem, but any comments are welcome.

  Cromemco System One - Update by Bill Degnan - 12/12/2007 19:17
Swapping cards to and from the system three, I have determined that there must be a ZPU setting that refers to the TU ART card for the system display. The 16FDC card works in the system three, but nothing appears on the display on the system one. hmmm.

  TUART roles by marcus bennett - 02/08/2008 18:50
Under Cromemco CDOS (i.e. CP/M lookalike in general terms) the console terminal should connect to the serial port on the disk controller i.e on the 4FDC or 16FDC or 64FDC. The Tuart provides 2 serial and 2 parallel ports to connect (for example) serial or parallel printers. Switch settings on the TUART set the IO addresses to be used. Using the assembler based Driver modification package you can create a custom CDOS operating system which could interface with a TUART set to any port address.

You might like (shameless plug) to visit our Cromemco Support site whose root of information is here:

From there you would certainly be able to see what switch settings do.

Oh yes, the ROM for the disk controller is at C000 hex so set any CPU card to power on and jump to that addresss.

Regards marcus bennett

  Cromemco Series One Update by Bill Degnan - 04/03/2010 20:00
At dinner I was inspired to mess with my Series One for the first time in two years. Within about 10 minutes I had the computer booting to the RDOS 2.52 prompt.

Here is how you cable the 16FDC for a 5 1/4" drive. Note that the card tells you where the ribbon cable stripe should be.

Taking it further....A thought-to-be working system diskette does not boot in this system on either drive. I suspect two bad disk drives, but I can't prove it yet. But at least I have a RDOS prompt finally.

Sometimes the message "stand by" comes up and the system hangs

Sometimes it makes it to this error:

Unable to boot
Err-B 34

RDOS 2.52 has a test program that is activated with the command "T"

1) The memory test returns an "X" on the C page.
0 1 2 3 4 5 6 7 8 9 A B C D E F
^ ^ ^ ^ ^ ^ ^ ^ ^ ^ x ^ ^ ^

The manual says an "X" is bad, but isn't this where RDOS is located? I can see the code is there, so I am not sure how to interpret the X vs. the ^. I have two 64K Cromemco memory cards, same results.

2) The test program continues and when I run a disk test on either A or B drive I get an error as follows, so I am looking for the error code list so I can troubleshoot the meaning of the error:

Seek tests:
01:error 30

Fortunately these systems came with Tandon drives so I can try another drive, after testing in an IBM PC to be sure it works OK first. I guess this system has two bad drives?

If I replace the drives and the system works, then I will let you know.

  Cromemco 4FDC by Bill Degnan - 04/05/2010 23:50
CDOS STAT command output

Definitely both original disk drives are bad. Fortunately I have more Tandon 100-2a's to try out.

Knowing that the two new test drives were good, I decided to focus on the 16FDC. I put a 4FDC inits place and I was able to boot from the A drive finally. I was not able to do anything with the B drive (no dir for example), I kept getting a Drive not Ready error. When I switch the drives around and swap the jumpers, I can boot with the formerly B drive as the A drive, so that tells me that maybe I have a drive board jumper setting problem. I have swapped numerous drives and the power connectors to be sure it's not a power problem. View pics of the original Tandon 100-2a jumper assignments for drive A and Drive B in a Cromemco System One. The terminator is in drive A.

The 16 FDC, using the same drives that worked with the 4FDC, hangs in a peculiar way. The drive motor starts out OK, but gets stuck in a pattern of jumps to the same few tracks over and over, but never engages past this to boot the OS.

Possible Conclusions
The 16FDC needs some sort of repair. Next - try testing the voltages. Fortunately I/O works at least.

The 16FDC has a jumper that is not compatible with the drives I am using? There is a jumper installed and I believe it's the one described on page 27 of the 16FDC manual. I might try taking this out to see what happens, or at least learning more about why it's there.

ALSO - play around with the jumper settings used for Drive B. That's the way the system came to me, but who knows what was done with this computer before I got to it!

  16FDC works in System by Bill Degnan - 04/06/2010 12:23
One more time.

Here is where things stand to clarify.
1. I now have a pdf of the 16fdc and I fully understand the switch settings/jumpers. I also have a 4FDC. I like to boot to RDOS and then run the B command to boot (or the BB command to boot to B when using the 16FDC.)

2. I have two systems that I am using for testing
a. Crom System One (5 1/4" Tandon 100-2a's)
b. Crom System Three (8" Persci 299 dual)

3. I have the correct drive jumpers, I have the correct terminator in place where it should be, as I switch things around.

4. Using the System One, I have two Tandon 100-2a's that will boot CDOS, using either the 4FDC and the 16FDC. If I take the boot disk out of drive A and stick it in drive B, switch to drive B and then run a DIR command I get a "Drive not ready" error for BOTH controller cards (repeating the experiment with either card installed). If I swap drives and repeat the same experiment I get the same result (boot from A, drive B not ready). I have been very careful to make sure I have the correct jumpers and terminator placement.

5. With the 16FDC in the System One I cannot boot to the B drive. The drive seeks up and down the lower tracks and never completes the boot cycle. ( this experiement is repeated with more than one working drive)

makes you think that there is a problem with the controller? But...I am not sure because both the 4FDC and 16FDC have the same exact problem with drive B not being ready.

6. The System Three has a bad A drive (disk detect issue), but the B drive is OK (this is a separate project). Using the 16FDC in the System Three I can boot to the B drive!

At least in the System Three the 16FDC is capable of booting a system to the B drive. The only thing I can think of is that the CPU or memory cards in the System One has issues preventing the drive ready signal from the B drive from being detected.

The next thing I will try is swapping the drive cable, and if that does not fix the problem I will swap the CPU and RAM cards from the System Three and put them into the System One to see if it boots directly to B.

  CDOSGEN was the answer by Bill Degnan - 04/09/2010 09:45
The problem was not the drive or the controller it was the CDOS gen. It was set to boot from a 5 1/4" drive as A, but the B drive was expected to be an 8" disk.

I needed to use CDOSGEN to generate a CDOS that expects the B drive to also be 5 1/4"

Thank you to the Cromemco Google User Group (Markus and Mike) for the tip about CDOSGEN:

First I made a backup of my only 5 1/4" disk:
After booting to RDOS and at the ; prompt:

(assume Return at the end of every line)

S0 (that's s0 "zero" not sO)
RD100 S7E00 1
WD100 S7E00 1
RD100 S7E00 1
WD100 S7E00 1
RD100 S6C00 1
WD100 S6C00 1
B (to boot CDOS to new disk)

then I ran CDOSGEN.
CDOSGEN (from MARCUS of the Crom group:)

Here is a sample session with CDOS 2.54

CDOSGEN version 02.54
Cromemco Disk Operating System Generator
Copyright (c) 1978, 1982 Cromemco Inc.

Memory size (3FFF through FFFF or 16K through 64K) ?

Drive A type (S = Small, L = Large) ? s
Seek speed (1 = 6ms, 2 = 12ms, 3 = 20ms, 4 = 30ms) <1> ? 1
Single or Double sided ? d
Single or Dual density ? d
Drive B type (S = Small, L = Large, H = Hard, N = None, E = End) ? s
Seek speed (1 = 6ms, 2 = 12ms, 3 = 20ms, 4 = 30ms) <1> ? 1
Single or Double sided ? d
Single or Dual density ? d
Drive C type (S = Small, L = Large, H = Hard, N = None, E = End) ? e

Function key decoding
(S = Standard, N = None, U = User, F = File) ? n

CDOS addresses:
Starting address of CDOS (top of User Area) C700
Starting address of I/O device drivers F944
Last address used by CDOS FF41
Top of memory for this CDOS FFFF
Size of CDOS 38AC
Size of boot loader (maximum = 1A00) 190B

Enter command file name - CDOS

To test type CDOS [return] with the new disk in the drive.



Buy a Commodore Computer Poster

Popular Topics and FAQs

  • Commodore B Series Tips and Tricks
  • Aerocomp TRS 80 M 1 Expansion Unit DDC
  • Items Wanted
  • Lobo Max 80
  • Zenith Z-19-CN
  • Prototype PET 2001 photo
  • Using Toggle Switches to Analyze Memory
  • Commodore Disk Archive Project
  • PET 2001 Prototype at Gametronics 1977
  • Jim Butterfield Photo
  • IMSAI 8080 With Processor Tech. Cutter
  • Secrecy is the keystone of all tyranny
  • Cromemco System Three
  • Northstar Horizon - Boot Problem
  • Computer History and Restoration Links
  • Commodore BX-256-80 - 8088 Co-processor
  • S-100 board testing with Z-80 ICE
  • Donner 3500 - an early portable computer
  • Digital (DEC) PDP 11/05 NC Assembly
  • Univac 1219 rescue
  • Fido BBS listing node list 6-13-1986
  • PDP 8e
  • MITS 88-2 SIO (2SIO) for BASIC
  • Visual Technology Inc Model 1050
  • Amiga 2500 Restoration
  • The Evolution Of IBM Computers
  • Replacement teletype print hammer head
  • Archiving and Copying Software 101
  • Computers Built 1940 - 1950
  • CBM B-520 (a.k.a B256-80 or B500 256)
  • RCA COSMAC Microkit
  • Commodore 64K C-116 Mods
  • MITS 8800b Turnmon 9600 baud
  • Catweasel, 8in and 5 1/4
  • Raspberry Pi as Gateway to Internet
  • Digital PDP11 late 1969 early 1970
  • PDP 11/40 72 inch cabinet model
  • PDP 11/40 Industrial 11 model
  • Digitial MicroVAX 3100 30 System
  • Digital VAX 4000-200
  • Commodore 64 / 1541 DRIVEKNOCK
  • Booting the System Using RL02 drive
  • PACS: Reflections by Kathleen Mauchly
  • Tele-Graphic Computer Systems Inc.
  • Commodore B Series SID Jukebox?
  • Installing Core into PDP 11/40
  • Setting Up OpenVMS 7.1 DNS CLERK
  • Felt-Tarrant Comptometer Model J
  • NextStation Color
  • Digital Rainbow (PC100-B2)
  • 1970 Compusad Compulogical Tutor
  • Archiving Papertapes Using DSI NC 2400
  • 1976 P.C.C. Features the MAI JOLT 6502
  • 1961 Beckman DEXTIR Computer
  • UNIVAC 1 and UNIVAC File Computer 1
  • Past Issues:

    tcf 2008 intel MCBS 10 control module

    This image was selected at random from the archive. Click image for more photos and files from this set.