Search Posts:

Northstar Horizon - Boot Problem


Return to Threads

  Northstar Horizon - Boot Problem by Bill Degnan - 12/31/2007 15:22
First the situation and then the questions

My formerly working Northstar Horizon will no longer boot formerly known-to-work boot disks. This system used to boot up a number of NS disks, worked very well with present hardware. Not sure what happened.

I did all of the standard stuff with chips and connections, but I did not do any electrical probing or anything like that.

Now, when the system is powered on the drive does not engage the disk. It spins for a spell and then stops. Both the A and B drives will spin together upon boot for 30 seconds and then stop. The left / boot drive is a Tandon TM100-2A with all the jumpers off. The right drive is a MPI model 52 with the first two jumpers on. I have temporarily disconnected this drive. I have a terminator jumper installed on drive A.

I have a North Star MDS AD3 controller/interface card with no visible modifications.
I tried a MDS card (model = MDS, without the AD3) and there no change - drives spin for 30 seconds then stop.

1) What is the correct jumper setting for the MPI model 52 to be "A" drive? I can't find it.

Here are some pics:

note - some of these are old pics, note the file dates.


  Update to Horizon Boot Problem by Bill Degnan - 01/09/2008 21:44
Found the MPI 91/92 Guide..may be close enough to get clues as to settings for a MPI Model 52 drive assignment.

  Replaced Processor card - success by Bill Degnan - 06/28/2008 21:59
I verified that the disk drive was OK, and I verified that the baud/terminal settings were correct. OK.

I was able to boot a NS disk (at least get a prompt) by replacing the processor card with another I had on hand. Good thing I had a spare. Not sure exactly what is wrong with the original other than some corrosion. I need to investiate further

  North Star Horizon Diskette Catalog by Bill Degnan - 07/08/2008 14:20
The second processor card died, which means that either I am simply unlucky or there is an electrical problem causing the processor cards to get fried. I am going to test the voltages being generated by the power supply, and the processor card's 7805 resistors. It's possible that they need to be replaced, and being of the same age, both fried with extensive use. I was able to make it through over 100 diskettes and test them all for data, OS boot, programs of all sorts. A higher percentage of disks work than I expected. These are the 10 hard-sector disks, but they are fully readable using the Northstar MDS controller and a Tandon 100 2a drive.

NOTE: I have three or four NS MDS controllers including a new one I built myself from a kit. I am reasonably confident that the drives, the controller and the terminal are working.

New Pictures (note file date 7-8-08)

  Northstar by Daniel Roganti - 07/09/2008 18:49

You need a Full-Time Support there to keep everything running :) If I didn't have to move right now I would be signing up !

If you lived closer, I'd be there every month (or more--but you might get tired of me)



  MPI model 52 by Bill Degnan - 07/09/2008 22:46
To you random person who has a MPI Model 52 5 1/4" inch full height diskette drive. The MPI jumpers are different than the Tandon 2a-100.

with G jumpers on: 2-5-7
dirve assignment will be = B

If possible put a t-res chip in F, you need at least one per drive set.

  Tandon 100-2A with Northstar MDA by Bill Degnan - 09/24/2008 22:01
If you have a Northstar Horizon with the MDA controller you can use a Tandon 100-2A disk drive, the same one that came with many IBM PC's, by jumpering TP11's 2nd switch (facing from the front) = drive A, and inserting a T-RES terminator in TP7. The terminator may be optional if you have more than one drive. The resulting jumpers will turn the drive into a boot disk drive for the Northstar Horizon. I have experimented with more than one of these drives to confirm.

  N* Horizon Motherboard Repair by Bill Degnan - 12/07/2008 19:57
Power leads on Northstar Horizon Motherboard

see page 31 of manual "Horizon Computer System Double Density" through page 37.

Power Leads
reset - grey (thinnner)
GND - black (thinnner)
-16V - yellow
GND - black from 11,000 uf cap.
+16V - orange
GND - 180,000 uf cap 1st wire
GND - 180,000 uf cap 2nd wire
+8v - red wire
+8v - other red wire

Drive A is not getting 5V (it's 1.3-2v)

Board is not sending the 5V to drive A

Had to determine whether 5v may also not be getting the controller cards - therefore the board is not bad, nor are the CPU cards.

Red wire coming from mother board +5v with P8 connector.

Need to replace the 7805 inside heatsink, 6030B, the front-most 7805.

  N* update - replaced 7805 regulator by Bill Degnan - 01/03/2009 21:59
I a processor card from Bill S, but it looks like that wasn't the problem.

1) Not getting 5V to the A drive (less than 2V). Traced the problem to the 7805 inside heatsink, 6030B, the front-most 7805. I replaced the 7805 and now I get the correct voltage to everything.

2) I checked every card, they all seem to be getting the correct voltages (12 or 5)

ZPB processor (also have a ZPB-2)
MDS-AD3 (also have a MDS)
IMS 4mhz 16K RAM set for top memory (I believe - checking to confirm)
N* 16K RAM bd (8000-Bfff)
n* 32K RAM bd (0-7fff)

3) I installed an in-circuit z80 emulator to check the memory (read / write test) - no errors through 7FFF. I can't write to anything above that, but the RAM is there, unsure why but I assume that this is part of an initial lockdown of RAM by design, as part of the bootstrap process (I have to confirm this). It's possible also that the emulator is not allowing the ROM to finish what it needs to do. Not worried at this point. I checked location E800 and what appears to be bootstrap code is located in this location (which is where the manual says it should be). I don't at the moment have a copy of the bootstrap code, but I assume I can find this on the web to confirm it's loading into memory. Looking for that now.

4) When I power on the machine, both drives spin but neither engage the boot disk. After maybe 20 seconds the drives stop spinning. I verified that the drive dip switches were correct from when the system worked. I also tried other similar drives (using Tandon 100-2A's). It's possible that I have the wrong settings,. but this is what worked before:
A DRIVE: Tandon 100-2A jumpering TP11's 1st and 3rd (facing from the front) and inserting a T-RES terminator in TP7 (FOLLOW UP: THIS IS WRONG, It should be just switch 2)
B DRIVE: MPI model 52 with G jumpers on: 2-5-7, terminator installed.

I must be getting close. I will let you know if I make more progress.

  Northstar MDS-AD3 listing by Bill Degnan - 01/04/2009 10:47
Bill S. sent me an email containing the bootstrap code he hand assembled of his Northstar MDS-AD3 ROM.


  N* back in business by Bill Degnan - 01/04/2009 21:55
Using my z80 in-circuit emulator, I confirmed that the disk controller bootstrap program was loading into memory. I researched the dip switches for the drive and determined that my dip switch socket was one place off. Moving the socket and resetting the dip switches, plus setting my terminal to 9600 b (for the left/corner serial port - voila I am back in business. FIXED.



Buy a Commodore Computer Poster

Popular Topics and FAQs

Past Issues:

vcfmw ECCC 2011 CBM 1551 drive

This image was selected at random from the archive. Click image for more photos and files from this set.